Testers wanted: candidate new TeXLive 2018.1 default bundle

#1

Hi all,

After far too long of a gap, I’ve finally started working on updating the default “bundle” of TeX support files used by Tectonic. — from TeXLive 2016 to TeXLive 2018.1. I’ve uploaded a candidate version to https://newton.cx/~peter/files/tlextras-2018.1dev.tar, which means that if you’re running version 0.1.9 or later you should be able to give it a spin with a command such as the following:

tectonic -w https://newton.cx/~peter/files/tlextras-2018.1dev.tar myfile.tex

If you have the chance, please give it a try and see if any problems crop up!

Furthermore, if you have a favorite package that’s been missing from the default bundle thus far, now is the time to reply here or file an issue on the tectonic-staging repository and put in a request. (Well, it’s always possible to add new packages later, but this is where my attention is at the moment.)

The default bundle has been upgraded to "tlextras-2018.1r0"
#2

Tectonic works well with the new bundle on a few documents I tried.

i only ran into what seems to be a bug in the microtype package: https://tex.stackexchange.com/questions/416310/problem-of-amsart-and-microtype-under-xelatex, but that is unrelated to tectonic.

#3

I have tried it, although I have no idea what the difference would be, but my build (see here) failed with

error: cannot write format file texput.fmt
caused by: this I/O layer cannot save format files

I’m sorry I don’t have time to figure out what the problem is, but maybe it helps you.
Source files are here if you’d want them.

#4

@PHPirates Are you running version 0.1.9? In older versions -w was broken, but it should work again as of the recent release.

#5

@rekka Just to check, does the fix recommended in that StackExchange post also work with Tectonic?

#6

Thanks, indeed I was using 0.1.8. It works now!

#7

@pkgw Yes, the fix works with Tectonic.

#8

Great! Based on this feedback, I will plan to switch the default bundle over to the new version around 13:00 UTC on Monday, Oct 1.