"something bad happened" using Travis CI

#1

I’m trying to use tectonic with Travis to build documentation using a docker image dxjoke/tectonic-docker. I was previously trying to use tex-live but I had massive font problems.

tectonic seemed to work as advertised, it pulled down all the packages and fonts as needed, but then it died inexplicably:

      .
   lots of happy stuff...
      .
    note: downloading ptmb7t.tfm
    note: downloading ptmri7t.tfm
    note: downloading ts1ptm.fd
    note: downloading ptmr8c.tfm

    error: something bad happened inside TeX; its output follows:

===============================================================================

===============================================================================

error: the TeX engine had an unrecoverable error

caused by: terminal input forbidden

which isn’t very informative. Debugging stuff on Travis is hard so I installed on my MacOS using conda and compiled the same file locally. Now I get

  .
lots of happy stuff...
  .
===========================================
Local configuration file hyphen.cfg used
===========================================
(hyphen.cfg (xebabel.def) (switch.def) (hyphen.tex) (dumyhyph.tex)
(zerohyph.tex) (dehypht-x-2018-03-31.tex
dehyph-exptl: using a TeX engine with native UTF-8 support.
(dehypht-x-2018-03-31.pat
German Hyphenation Patterns (Traditional Orthography) `dehypht-x' 2018-03-31 (W
L)
! Nonletter.
l.144 .ä
     m3
No pages of output.
Transcript written on texput.log.
===============================================================================

error: the TeX engine had an unrecoverable error
caused by: halted on potentially-recoverable error as specified

It’s tectonic 0.1.11 in both cases. It’s barfing in the hyphenation file not my .tex file, the online documentation refers to a 2019 version of this “experimental” package. Don’t know why the old version is being used.

Not sure if these are the same error, or now I’m chasing two quite different errors. Any wisdom would be appreciated.

#2

If I remember correctly Tectonic draws packages from a package tarball which is updated when @pkgw feels like updating, so that would explain any old packages being used.

Unfortunately I can’t really help you with the error, but maybe it would help if you would provide a minimal example latex file which reproduces it?

FYI Last week I started with attempting to install custom fonts on Travis with TeX Live, because yes that was still missing in https://github.com/PHPirates/travis-ci-latex-pdf so any test file which uses some obscure (but public) font is welcome :slight_smile: (including German unicode characters or whatever you are using)

#3

Your site has been helpful to me in this process. The ME that causes the problem locally is

\documentclass{article}
\begin{document}
hello
\end{document}

so it must be an install issue, I have no idea why German hyphenation is involved at all.

Fontwise I’m using

\usepackage{times}
\usepackage{mathptmx}
\usepackage{anyfontsize}
\usepackage{amsfonts}  % mathbb font
\usepackage{t1enc}
\usepackage{textcomp}

I think I’ll go back to tex-live docker and use the recommended-fonts package to see if that helps.

#4

@pic Hm then there must be something wrong in (your installation of) tectonic.

As for the fonts, the packages you mention behave like any normal packages for me: https://github.com/PHPirates/texlive-travis-font-test is a setup with TeX Live (not using docker) that you could use. But that’s a bit off-topic here, please create an issue on one of my repos if you want more help with the Travis setup :slight_smile:

#5

Updated when I feel like it … or when asked! At least, that’s what I aspire to. I have tried to make the tarball-construction process reproducible (recipe here) so that hopefully that process won’t be a bottleneck when updates are needed.